Разработка в 1С 8.0



Код:


ПроцедураОбработкаПроведения(Отказ, Режим) 

//проверка остатка производится   

//только при оперативном проведении   

Если Режим = РежимПроведенияДокумента.Оперативный Тогда   

Если ОстатокНаСкладе < СтрокаСостава.Количество Тогда   

Сообщить("Товара "+СокрЛП(СтрокаСостава.Номенклатура)+"имеется только"+Остаток);  

Отказ = Истина;  

Возврат;  

КонецЕсли;  

КонецЕсли;  

КонецПроцедуры

При удалении документа или при отмене его проведения движения документа обычно удаляются автоматически, но это можно регулировать установкой параметра «Удаление движений». Для некоторых видов документов разработчик может отменить данную возможность и управлять удалением движении самостоятельно через свойство Движения, предоставляющее доступ к коллекции движений документа.  




Содержание  Назад  Вперед