Разработка в 1С 8.0



         

Код:


ПроцедураСписокПриВыводеСтроки(Элемент,ОформлениеСтроки,ДанныеСтроки)  

СтруктураОтбора = Новый Структура("Номенклатура");  

СтруктураОтбора.Номенклатура = ДанныеСтроки.Ссылка;  

РегОстатки = РегистрыНакопления.УчетНоменклатуры;  

//считываем остаток из регистра  

тзОстатки = РегОстатки.Остатки(,СтруктураОтбора,  

"Номенклатура","Количество");  

Если тзОстатки.Количество() > 0 Тогда  

ОстатокТовара = тзОстатки[0].Количество;  

ЯчейкаОстаток = ОформлениеСтроки.Ячейки.Остаток;  

ЯчейкаОстаток.ОтображатъТекст = Истина;  

ЯчейкаОстаток.Текст = ОстатокТовара;  

Если ОстатокТовара < 10 Тогда  

ЯчейкаОстаток.ЦветФона = Новый Цвет(255,230,230);  

КонецЕсли;  

КонецЕсли;  

КонецПроцедуры  

На практике остаток товара лучше сравнивать не с конкретным значением, а с критическим уровнем запаса каждого товара, который определяется исходя из потребности в данном товаре. Заметим, что такой сервис предъявляет довольно высокие требования к производительности компьютера, потому что при каждом обновлении списка заново считываются данные из регистра, поэтому так делать крайне не рекомендуется. Этот пример был специально приведен, чтобы показать,




Содержание  Назад  Вперед