Разработка в 1С 8.0



         

Код:


сзСотр = Новый СписокЗначений; 

сзСотр.Добавить("Иванов",,Истина);//пометка установлена 

сзСотр.Добавить("Петров");//пометка не установлена 

сзСотр.Добавить("Сидоров");//пометка не установлена 

 

ВыборПроизведен = сзСотр.ОтметитьЭлементы("Укажите сотрудников");

 

Если ВыборПроизведен Тогда

Для Каждого эл Из сзСотр Цикл  

Если эл.Пометка Тогда  

Сообщить("Отмечен сотрудник " + эл.Значение);  

КонецЕсли;  

КонецЦикла;  

КонецЕсли;

Методы ВыбратьЭлемент и ОтметитьЭлементы открывают диалоговое окно для пользователя, в котором он может выбрать один элемент или расставить пометки, тем самым выбрав несколько элементов.  

 

Элементы списка значений могут быть легко отсортированы по значению или по представлению:  




Содержание  Назад  Вперед