Разработка в 1С 8.0



         

Код:


Процедура ПоказатьПодчиненные (СтрокаДерева,Уровень=0) 

Для Каждого стр Из СтрокаДерева.Строки Цикл   

отступ = "";  

Для н = 1 По Уровень Цикл  

отступ = отступ + " ";  

КонецЦикла;  

Сообщить(отступ + стр.Отдел);  

ПоказатьПодчиненные(стр,Уровень+1);  

КонецЦикла;  

КонецПроцедуры

 

ПоказатьПодчиненные(дзОтделы);

 

Результат работы программы:  


Бухгалтерия

Расчет зарплаты  

Основные средства  

Руководство

Высшее руководство  

Отдел маркетинга  

Аналогично таблице значений, дерево значений позволяет искать значение с помощью метода Найти или искать сразу несколько строк методом НайтиСтроки. Принципы работы этих методов полностью идентичны рассмотренным выше для таблицы значений, за исключением последнего параметра ВключатьПодчиненные. Если передать в него значение Истина, то поиск будет производиться в том числе и по подчиненным строкам, иначе ?только по строкам текущего уровня.  

 




Содержание  Назад